欢迎光临杨雨的个人博客站!

杨雨个人网站-杨雨个人博客-杨照佳

杨雨个人博客网站

关注互联网和搜索引擎的个人博客网站

首页 > WEB开发 > Python教程 >

python3.6.4如何安装到树莓派3代

发布时间:2019-06-29  编辑:杨雨个人博客网站   点击:   

树莓派目前能用sudo apt-get install安装的默认最高是Python3.4,但是很多Python3.6+的新特性都无法使用,自己的项目也无法运行。所以需要把它升级。

python3.6.4如何安装到树莓派3代

目前无法简单安装,只能自己make编译。(推荐学习:Python视频教程
我们要在树莓派安装的是Python3.6.4,所以我们要编译安装这个版本。

方法如下:

# 安装编译所需依赖包
sudo apt-get install build-essential tk-dev libncurses5-dev libncursesw5-dev libreadline6-dev libdb5.3-dev 
libgdbm-dev libsqlite3-dev libssl-dev libbz2-dev libexpat1-dev liblzma-dev zlib1g-dev

# 安装SSL依赖
sudo apt-get install libssl-dev


# 到官网下载Python3.6.4: https://www.python.org/downloads/source/
wget https://www.python.org/ftp/python/3.6.4/Python-3.6.4.tar.xz

# 解压
tar xf Python-3.6.4.tar.xz 

# 进入目录
cd Python-3.6.4

# 开始编译(时间漫长,需要等待,建议用&&把三句连在一起执行)
sudo  ./configure
sudo make
sudo make install

# 升级pip
sudo python3.6 -m pip install --upgrade pip

安装好Python3.6后,会显示:

python.png

更多Python相关技术文章,请访问Python教程栏目进行学习!

以上就是python3.6.4如何安装到树莓派3代的详细内容,更多请关注杨雨个人博客其它相关文章!

本文地址:http://itbyc.com/Python/22201.html
转载请注明出处。
分享是一种快乐,也是一种美德:
博客首页 | WEB开发 | 网站运营 | CMS使用教程 滇ICP备14002061号-1